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Basics about GPS for hiking 
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Abbreviations used 

• GE  Google Earth (free software for computers) 

• GPS  Global Positioning System 

• OM  Orux Maps (GPS application for Android phones) 

• POI  Point Of Interest (on a map) 

• WP  Waypoint 
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GPS 

Global Positioning System  

 
• Several satellite around planet Earth, broadcast GPS “signals”: 

– GPS devices receive satellite signals… no transmission 

– Weak signals from remote satellites, so…  
• perceptible Outdoors only! 

• 1st “GPS fix” requires user to be still (not moving) 

 

• Origin of GPS systems 
– USA: NAVSTAR 

– Russia: GLONASS (since 2010) 

– UE: Galileo (available in 2020).  

 

• Goals of GPS systems: 
– Basic goal: knowing your position on a map 

– Navigation: sea, land (car) 

– Orientation: hiking trips 
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GPS maps 

Typically a digital map is either  

 
• A sophisticated software object comprising a 

drawing of the landscape (with roads, public 
monuments, …) + a database of POIs + some 
intelligent software capable of giving you 
directions to reach your destination POI.  

– Requires Internet connectivity, to access the 
latest maps and POIs. 

– Usually expensive 

Example Google maps 

 

• Or a simple picture, showing the landscape 
and possibly the roads. 

– No navigation capabilities but… 
Ok for hiking! 

– Can be used off-line by  
software like OM 

– Usually available free of charge 

– Ex: Google Earth/ Hybrid 
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GPS objects - Waypoints 

• A Waypoint is a point on the map, created in order  
to locate an important place on the map… 

 

– either by the “Create waypoint” function of the OM mobile 
(marks the user’s current location) 

– Or by clicking a point on the “Map” 

– Or by some software 

• On Google Earth it is called a Placemark. (Add → 
Placemark) 

• On Nokia phones it is called a landmark 

 

• Any WP can be used as target for orientation 
– A compass indicates the direction and the distance to it. 

See page 26. 
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GPS objects - Routes 

• A Route is an ordered set of waypoints, 
used to guide you throughout your hike. 

 

• It is created from waypoints … 
– on the mobile, with software like OM 

– Or on the laptop using some software  
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GPS objects - Tracks 

 

• A Track is a path walked by a hiker and recorded on his GPS 
device.  
– Used after your hike, to locate where you’ve walked and get statistical 

data.  

– A track recorded by another hiker could be uploaded to your GPS 
device (e.g. smartphone) and used to walk along this track as shown on 
your mobile’s map.  
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File types – Useful software programs  

• File types: 

– Each GPS vendor has developed its own GPS software which uses proprietary 

file types to describe the GPS objects. Example :*.lmx, *.trk, *.loc, *.hwr, etc. 

• Garmin navigators use *.gdb (Garmin database, version 3) 

• Google Earth uses *.kml (keyhole markup language)  

– The .gpx type was created as an effort to have a common file type, normally 

understood by all GPS navigators and GPS software. 

• A gpx file may contain any combination of WPs, routes and tracks. 

– OruxMaps uses .gpx and .kml types 

• Useful software programs to have: 

– Google Earth is great for planning hikes! It requires a fast Internet connection. 

– A software to translate between all the different file types: 

• “GPS Babel” is the freeware to use. 

– A software to view a track on a map and get statistical information about it: 

• “GPS Track Viewer” is a good freeware, or on line, for example at 

http://gpstrackviewer.free.fr/  
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Navigation towards a target point 

• A few basic definitions 

– The target, is the next waypoint you want to 

reach on your route 

– The heading, in degree (0° to 360°, 0° being 

the north, 90° the east), which is the angle 

between the geographic north and the 

current direction you are looking at (the 

orientation of your phone); (ex: +30°) 

– The bearing of the target, in degree, which 

is the angle between the geographic north 

and the targeted waypoint, at your current 

location; (ex +120°) 

– The direction of the target, in degree, which 

is the angle between your current heading 

and the bearing of the target, at your current 

location; (ex : 120° - 30° = +90°) 
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Before the hike 

1. Downloading a digital map 

 

 

2. Preparing to follow a route 

 

 

3. Preparing to follow a track 
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Downloading a map 
for off-line use 

Before you go hike in some nice place… you need to have a digital map of that 

place, accessible off-line on your mobile. 

• With OM, you can Create a map easily, for off-line use 

– Make sure you have Internet connection on your mobile 

– In the Maps menu, select Switch map, then select the ONLINE tab. 

– Select your preferred map type, among the dozens proposed: 

• Good worldwide map types are Google Hybrid and Microsoft Hybrid 

• Look for the best available map covering the area of the planned hike 

• Check the max zoom level you want to have. 

 

– In the Maps menu, select Map Creator         

• Select the map area you want to download: click 2 opposite corners of a rectangle, then 

ok  

• Input a map name 

• Select the zoom levels you want (usually min= 10, max = 16, 17 or 18) 

– Check the map size in Mb (max = 1024 Mb), decrease max zoom level if needed. 

• Tick Don’t stop downloading if there are missing tiles’  then click Download 
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Planning a hike 
Creating a Route or Importing an existing track 

• When you want to go hiking, in a place which you do not know well, 

there are 2 ways to find your way: 

1. Using a software like GE, create a route = a set of several successive 

waypoints you intend to walk by, presuming there is a way to walk from 

one WP to the next. 

 

 

2. Or, it is possible to hike along a track recorded by someone else… 

• from Wikiloc website or any other similar site = a database of tracks, or 

• sent to you by another GPS user you know, or even 

• recorded by yourself during a previous hike  

 

In both cases, in order to exchange files between your computer and your mobile, 

you could create once and for all, the following folder on your mobile: 

…/oruxmaps/file_exchange  

 

 

 

14 



OM  

mobile 
N waypoints + 1 Route 

N placemark files 

• kml files 

Import the kml file into OM 

Create & Save N placemarks 
File→ Save Place As…*.kml  

Google Earth (3D) 

Connect mobile,  

Copy kml file to device 

• 1 kml file 
N waypoints 

PC file manager 

N times 

 

 

 

 

 

 
Merge N placemarks 

 into 1 kml file 
N x File→ Open 

  then Save Place As…*.kml  

Build a Route  
OruxMaps 

Save it as KML  
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Planning a route using GE (overview) 



Planning a hike route using GE (1/2) 

Creating & importing the waypoints to the mobile device 
 

• Planning a hike route = creating N placemarks on GE 
– On your computer, using GE : 

•   repeat N times: Create several Placemarks on planned hike : Right-click 
on each of these placemarks, then select Save place as Plxx.kml.  

• Close GE. 

• Then merge these N files: re-open GE, File→Open then select all N files 
together (shift click). They appear in the left pannel under Temporary 
Places. Right-click this folder  name and ask to Save Place As kml.  

–  Connect laptop to mobile, (unlock mobile screen). Then using 
windows file manager: copy the unique kml file to the mobile, under 
…/oruxmaps/file_exchange 

–  Using OM, Import the waypoints : Open the Waypoints menu, and : 

• Select Manage 

• Click Options android button, and select Import Wpts. 

• Select the folder /oruxmaps/file_exchange 

• Double-click on the the kml filename to import the WPs inside 
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The procedure described in this slide can also be used to import WPs 

from GE into OM (without aiming at creating a route)  



Planning a hike route using GE (2/2) 

Creating a route file using OM  
 

–  Using OM, Build the Route: 
• Open the Waypoints menu, and select Manage 

• Use the Search menu or the Filter Menu to select  only the WP making up 
your Route 

• Change the order of the WP by moving WPs up and down (point on left side 
icon  ) 

–  When finished Save the route  
• Click the Export button          then select “KML”  

  

 

 

The Route can now be seen as file “Waypoints__yyyymmdd_hhmm.kml” in 
the oruxmaps/tracklogs folder of the mobile.  

 

Such a route file can be loaded anytime later and used for waypoint 
navigation. See slide Route navigation 
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OM  

mobile 
[N waypoints +] 1 Track 

Connect mobile,  

Copy kml file to device 

• 1 gpx file 
[+N waypoints] 

PC file manager  

 

 

 
OruxMaps 

Wikiloc 
(or any other 

similar website) 

www.wikiloc.com 

 

 

Internet Browser 

Or Download track 

file from website 

 

Check your track file 

 was correctly received 

By Email  

 bis 

Save track file 

(from email) 
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Importing an existing track (overview) 

http://www.wikiloc.com/


Importing an existing track 

• How to proceed  

– Go to the Wikiloc webpage  http://www.wikiloc.com 

• Search for some track you like to walk (you can preview it on GE) and  

• download it to your computer, as a *.gpx file 

– bis Or save a .gpx track file received by email 

–  Connect your Mobile to your computer and, using windows file 

manager, copy the *.gpx track to it, for example under 

…/oruxmaps/tracklogs 

–  On OM, check the presence of the imported file 

• Either by using the  Route menu:               → Load file  

• Or by using a mobile file manager  

 

– Other websites:  

• www.gpsies.com  

• www.mapmytracks.com  
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It’s hiking day! 
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Starting the hike 

At the starting point of the hike:  

1. Switch on GPS reception on the Android phone 

2. Launch OM and set GPS tracking On          (also available in tracks menu). 

3. Load the Offline map covering your hiking area 

• In the Maps menu, select Switch map, then the OFFLINE tab 

• Optionally, load the WPs on the map (Select all WPs , then ‘eye’) 

4. Load (or create) the Route you intend to follow (see next slides) 

• to record your track, press “Start recording”          

 in Tracks Menu 

– Or Load the Track you intend to follow (see next slides) 
 

5. Optionally, (for more safety), mark on the map the starting place by 
creating a new waypoint. 

• If you know the exact altitude of this starting point, you could calibrate your 
altimeter, (Options → Tweaks → Calibrate barometer) 
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Start walking and follow your GPS indications 



Route navigation 
(Called in OM  “Waypoint Navigation”)  

1) From a previously created route 

KML file,  

a) Click button ‘Routes’ then → ‘Load File’  

b) Double-click the desired file name 

“Waypoints__yyyymmdd_hhmm.kml” 

c) Then in pop-up window called“Navigation 

options” select ‘Wpt. Nav.’ 

2) Or from a set of Wpts in OM: see slide 
Creating & following a route in OM (from existing WPs) 

3) Or from nothing : route created directly on 

map. See slide 25. 

 

 The Wpt. Alarm plays an alert message when 

you approach each WP 22 



Options during waypoint navigation 

Useful to navigate 

the route backwards 

Stop the navigation  (at 

the end of your hike) 

Adjust your target WP 

as you walk (in case you 

missed a WP) 

Stops playing the warning 

audio message when you 

approach a target WP 
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Options available in the Maps 

menu, during Navigation 



Creating & following a route in OM 
(from existing WPs) 

You have in your database plenty of WPs. You can select a few 

of them to make a Route, and start immediately following it 

 

1. List all your WPs: Button 'Wpts.         →  manage' 

2. Browse the entire list, or use Search function, and tick the checkbox 

 to the left of the WPs you wish to include in your Route. 

3. Once you have selected all WPs, use WP 'Filter' option with option 

'Selected Items‘ . By clicking on the 'ok', in the listing should appear 

only the desired WPs. (Or Filter by some other Wpts characteristics).  

4. Reorder the Wpts as desired: hold the icon of the far left of each WP 

(drag and drop the Wpt up/down)  . 

5. Upload the route to the map viewer: press the second button from the 

left of the button bar (Routes). 
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Creating a route in OM (1/2) 

(without anything, directly on the map) 
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You don´t have a prepared Route or Track, nor even WPs. You can 

still plan a route, directly on your OM\s map viewer.  

To Create the route manually:  

1. From the map viewer, Select button 'Tracks’→ Create'. 

This opens a box at the bottom of the screen, used to add Route points by 

hand (and simultaneously create a WP if the checkbox 'Create Waypoint' 

is active).  

2. To do this move the map with your finger, place the cursor () where you 

want to put the Wpt. and press the  button. To erase the last WP created, 

use the '-' button. To complete the route, press the button 'OK' ; and to 

exit and cancel the route, select the  button.  

3. Now you have the Track file created and stored in the database. Then 

remove it from the screen (from the map viewer, button 'Tracks→Remove') 

… 



Loading & following a route in OM (2/2) 
(from a hand-created route) 

You have created in your database a 

route manually (prev. slide). You intend 

now to follow it. 
 

1. From the map viewer, select ‘Tracks’ or 

‘Routes’→ Manage. Some routes are 

listed.  

2. Click on the filename of the route you 

want to follow (Called “yyyy-mm-dd  

hh:mm”) and select from contextual menu 

“Load as a Route” 

3. Chose ‘Wpt. Nav.’ from pop-up window. 

2013-06-28 14:28 
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Navigation to a target WP 
Using OM’s compass “Radar (TC-4)” – Options, Tools, Radar 

Estimated  

Time of  Arrival 

Estimated Time Enroute 

Target ‘s icon 

Direction of 

the target  

(wrt mobile) 

Target’s name 

GPS accuracy 

Bearing 

angle between the 

target & the North 

(Fixed  if you do 

 not move) 

Heading 

the direction of the 

mobile (0 ◦ = N) 

Distance to  

the target 

Heading 

Angle between the  

mobile and the North 

(varies if you rotate the phone) 

If you rotate the mobile 

until the 2 arrows  coincide 

→ you’re headed straight 

towards the target) 

ex both angles = 126◦ 

Heading = Bearing 

Select WP & Navigate To 

Or follow a Route (Wpts Navigation) 
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Heading straight towards the target WP 

If you rotate the mobile until the 2 

arrows coincide → you’re headed 

straight towards the target! 

 

Heading = Bearing (ex 310◦) 
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Following a recorded track 

Load the track path on the map viewer of OM:  

– Select the Route menu:        → Load file  

– In the /file_exchange folder, double-click the 

gpx filename (e.g. Chabrouh-Hrajel.gpx). 

– In the Navigation options pop-up window , 

select Follow, click OK 

– Select a map covering the area, and start 

walking along the drawn path. 
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Finishing the hike 

 

At the finishing point of the hike 

• In OM: 

– Stop the navigation (in Maps menu, “Stop Follow” or “Stop Wpt. Nav.”) 

– If track recording was on, Stop it by pressing “Stop recording”          
 in Tracks Menu 

– Set GPS tracking Off   

• On Android notification screen, 

• Switch off GPS reception  
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After the hike 

 

1. Get some instant statistics 

2. Visualize in 3D on your computer the path you have walked! 

– Make sure you have ticked these 2 options in the OM settings for Tracks/Routes : Auto 

KML creation and Auto GPX creation 

3. Share your track on wikiloc ! 
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Instant statistics on OM 

At the end of the hike (and during the 

hike), you can get some statistics 

directly on your mobile: 

• In OM, in Tracks menu, Select 

“Statistics” 

– You get a lot of interesting statistical 

data about your hike. 

– See example here 

 

 

 

 

• Click on “See Graphics” button to see 

the profile of your hike 

– Tick Altitude and /distance  
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OM  

mobile 
[N waypoints +] 1 Track 

Open kml file  

Google Earth (3D) 

Connect mobile to laptop,  

Copy kml file to laptop 

• 1 kml file 
N waypoints 

PC file manager 

 

 

 

 

 
OruxMaps/tracklogs 

Track elevation 

profile 

Track path 
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Path visualization in 3D (overview) 



Path visualization in 3D 

At the end of the hike, the trackfile is saved on the mobile as gpx and kml 

files (in oruxmaps/tracklogs folder) 

 

•  Connect the mobile to your computer and, using the file manager 

•  Copy the .kml (and .gpx if needed) to your laptop.   

– Optionally: you can view the .gpx track profile + statistics using some GPX viewing 

software or website: Using an Internet browser: Go to gpstrackviewer.free.fr website, 

upload *.gpx track file to view the track in 2D. Optionally you can click the button 

“obtain a URL” and send the link to your friends in your report. 

•  View the track in 3D using Google Earth:  

– Launch GE, select File→ Open and open the .kml file. Right-click anywhere on the 

path (between 2 track-points) and select “Show Elevation profile” . 

• Optionally report your hike to your friend by email: attach the *.kml track file  

– report the main statistical data: track length, time, total ascent, max elevation…  
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Sharing your track on Wikiloc 

PC file Manager 

Cleaned-up track [+ wps] 

• gpx file + 6         +   

Check track on GE 

Click link ‘View in 3D in 

 Google Earth’  

Wikiloc 
(or any other similar website) 

www.wikiloc.com 

 

 

Internet Browser 

Upload to website  

3D view: Google Earth 

 

 

Only if the hike is worthy 

of being shared with the 

global hikers’ community 
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Posting your track on Wikiloc 

• You have to create a Wikiloc account, once and for all, to be able to 
post (upload) tracks. 

–  Go to www.wikiloc.com website and select Sign up. 

• Posting your track 

– Preparation on your computer   

• Your recorded trackfile in gpx format 

• Some interesting waypoints added during the hike, also in gpx format (use 
GPS Babel if needed)  

• A maximum of 6 photos taken along the way (reduce their size first) 

• A short text description and counsels (driving directions, shuttle, views…) 

– Using your Internet browser: 

• Go to www.wikiloc.com, Sign in to your account, 

• Ask to upload a new track 

• upload the *.gpx track file and optionally the waypoint files 

• Paste your description text, Upload the photos (it is possible to add a legend to 

each photo). 
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The End 
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